Results 1 to 4 of 4

Thread: KWA Kriss Vector Firing Full Auto On 2 Burst

  1. #1
    Join Date
    Sep 2015
    Posts
    64

    Default KWA Kriss Vector Firing Full Auto On 2 Burst

    Recently received a KWA Kriss Vector, it fires perfectly except that in 2 burst it only fires full auto.

    I have stripped it down to the trigger bar and can't notice any damage or bending.

    Anybody have any idea what could be causing this issue?
    Thanks.

  2. #2
    Join Date
    Nov 2008
    Posts
    1,456

    Default Re: KWA Kriss Vector Firing Full Auto On 2 Burst

    Need a new burst sear. Absolutely pita to fit. Available from KWA Direct

  3. #3
    Join Date
    Jun 2012
    Posts
    115

    Default Re: KWA Kriss Vector Firing Full Auto On 2 Burst

    you reckon you can still source parts from the vector from them?

    - - - Updated - - -

    Even if you can't.. (i didnt think you would be able to ) you can order one from rainbow8

    https://www.rainbow8.com/products/burst-sear-part-no-35-for-kriss-vector-gbb

  4. #4
    Join Date
    Sep 2015
    Posts
    64

    Default Re: KWA Kriss Vector Firing Full Auto On 2 Burst

    @StargateP90 Do you know which is the burst sear? Is it one of the 3 on springs when you take the trigger housing out or is it one of the metal pieces in beside the hammer?

    Thanks for the response.

    - - - Updated - - -

    @Jasont21 Thanks for the help, I saw this piece when I was inspecting the trigger bar and it looked completely fine, like new. Do you still think it could be the issue?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
 
Zero One Airsoft - Your One Stop Airsoft & Tactical Online Superstore
Zero One Airsoft Ltd. Office Telephone: 01202 769614
Units 8 & 9, Branksome Business Park
Bourne Valley Road Tech Telephone: 01202 769615
Poole
Dorset Email: info@zerooneairsoft.com
BH12 1DW
United Kingdom Web: www.zerooneairsoft.com